Archive

Articles taggués ‘mod_ssl’

Mod_ssl VS gnutls, mpm-worker problem

If you have problems with mod_gnutls since Squeeze. This might confirm something, at least if you use the multithreaded mpm-worker.

3 reasons for not using gnutls :

1 - No active development, same version for Squeeze, Wheezy and Sid

2 - Current version create a segmentation fault with apache server on Squeeze

3 - Just not compatible with apache2-mpm-worker on Squeeze
    Will break your SSL websites and pull your hairs off!

 

I just had to move back to mod_ssl

You need Apache2 >= 2.2.12
You need OpenSSL >= 0.9.8g

 

Hope this is helpfull to someone.