Archive

Articles taggués ‘lenny’

Lenny, monter un disque dur USB (externe)

Disque Dur Externe Sous Lenny :

aptitude update
aptitude install pmount ntfs-3g

 

Debian : ajouter un paquet testing dans Lenny (backports)

debian_cubism_comp

J’ai besoin d’utiliser un paquet plus récent que celui de la distribution principale Debian.
Peut-être pour en finir avec MySQL et SSL
Toutefois, je ne souhaite pas changer ma Debian stable pour une testing. La solution : utiliser les backports.
La version « backport » d’un paquet restera dans tous les cas compatible avec la distribution stable.

 

Il faut donc : Lire la suite…

Création de certificats SSL pour MySQL avec openSSL

La création de certificats de sécurité SSL au moyen de openSSL devient assez facile après quelques usages. Voici comment créer des CA (certificate authority) qui permettront une communication SSL entre 2 serveurs MySQL. Lire la suite…

Connexion SSL MySQL OpenSSL sur Debian Etch et Lenny

MySQL-SSLIl y a un problème dans Debian Etch et Lenny pour les connexions MySQLSSL.
Lorsque vous essayez de vous connecter à distance sur un serveur MySQL en SSL, vous risquez de rencontrer l’erreur suivante : « SSL connection error ».

Cette erreur est due au fait que MySQL n’est pas compilé avec openSSL dans ces distributions.

Pour utiliser SSL, vous devez recompiler MySQL. Je n’ai pas réussi à recompiler la version backports de Etch… (pas de répertoire debian/rules). Je vais donc recompiler la version de Lenny dans Etch. Cette astuce fonctionnera tant et aussi longtemps que Lenny utilisera la version 5.0 de MySQL.

Il y a un autre bug dans MySQL sur Etch : pas moyen de faire un mysqldump en SSL.
mysqldump: Got error: 2026: SSL connection error when trying to connect
http://bugs.mysql.com/bug.php?id=27669
Il semble que ce bug ait été réglé dans la version 5.0.42 de mysql.
C’est pourquoi j’ai besoin d’une version instable de MySQL sur Debian, la version stable étant 5.0.32.

Voici la marche à suivre pour régler ces problèmes.

Lire la suite…